Unfortunately, we do not have a 64-bit version of our software.  This is required by Apple to use Catalina and Big Sur. We will be re-evaluating future compatibility after our next release.  Currently, if you wish to use our software on a Mac, one option is to setup a dual boot with an Older Mac OS such as Mojave. We have a free 30 day trial available on our website we encourage you to take advantage of to verify this setup will meet your needs. Download files are on our website at: https://www.mackichan.com/products/dnloadreq.html


The recent Macintosh models that use the new M1 chip do not appear to support Dual Boot or virtual computer software such as Parallels and VMWare.  This means that virtual machines are not a solution in the medium to long term for M1 based Macintosh computers.